AMiLDA FORUM

You are not logged in.

Announcement

### Our Homepage is down at the moment...work in progress !! ###

#1 2006-10-19 21:40:02

TiTaN_pi8
Member
Belgium
Registered: 2006-04-15
Last visit: 2006-10-19
Posts: 10

MTD support

Hello,

I have compiled my own firmware using AMiLDA's kernel. I made a root filesystem using buildroot (uclibc + busybox). Now I would like to use the Flash chips to store some settings. I have compiled MTD support into the kernel. When I boot I see this:

MX29LV320B flash device: 200000 at 1fc00000
Amd/Fujitsu Extended Query Table v1.0 at 0x0040
number of CFI chips: 1
cfi_cmdset_0002: Disabling fast programming due to code brokenness.
Creating 5 MTD partitions on "MX29LV320B flash device":
0x00000000-0x00200000 : "Flash Disk 1"
0x00000000-0x00008000 : "Boot Partition"
0x00008000-0x00010000 : "Config Partition"
0x00010000-0x00020000 : "Data Partition"
0x00020000-0x00200000 : "System Partition"
MX29LV320B flash device initialized
ftl_cs: FTL header not found.
ftl_cs: FTL header not found.
ftl_cs: FTL header not found.
ftl_cs: FTL header not found.
ftl_cs: FTL header not found.
NET4: Linux TCP/IP 1.0 for NET4.0
...

And when I try to unlock the mtd devices:
# flash_unlock /dev/mtd1
Could not open mtd device: /dev/mtd1

# flash_info /dev/mtd1
Device /dev/mtd1 has 0 erase regions

# ftl_check /dev/mtd1
Memory region info:
  Region size = 32 kb  Erase block size = 16 kb

No valid erase unit headers!

Am I missing something here or is there no full support for the MTD partitions in the AMiLDA kernel?
Has anybody been able to successfully store stuff on the flash chips?

Thanks a lot!

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2008 PunBB