AMiLDA FORUM

You are not logged in.

Announcement

### Our Homepage is down at the moment...work in progress !! ###

#1 2008-02-07 14:20:33

Dafo
New member
Registered: 2008-02-07
Last visit: 2008-02-07
Posts: 3

Is my bootloder broken?

Hi,

On power up I got:

    ADM5120 Boot:
    no sys signature found!!

    jump to linux code!!

and then the system hangs.

Does this mean that the bootloader is broken and there's no way to recover without JTAG?

Offline

 

#2 2008-02-07 18:12:07

MrZack
Administrator
Austria
Registered: 2006-02-15
Last visit: 2017-10-23
Posts: 106

Re: Is my bootloder broken?

Hi,

It looks like something happened with the linux image. The boot loader jumps to the starting point where the linux kernel should boot, but the right data is not there. I had this ones... the reason was a firmware upgrade gone wrong for some reason.
But not to worry smile ... you don't need the JTAG cable, you can do this with the RS232 cable.
It's always good when you get the "ADM5120 Boot:", because then you can press the space 3 times to get into the bootloader menu, where you can update the firmware.

You can find more info here: http://forum.amilda.org/viewtopic.php?id=37


Nothing is impossible....except that the state of your mind makes it so.

Offline

 

#3 2008-02-07 18:20:30

Dafo
New member
Registered: 2008-02-07
Last visit: 2008-02-07
Posts: 3

Re: Is my bootloder broken?

I answered my question myself.
Bootloader is OK.
My MAX3232 implementation was buggy so the triple 'spacebar' didn't get to the router.

thanks

Offline

 

#4 2008-02-07 18:23:30

Dafo
New member
Registered: 2008-02-07
Last visit: 2008-02-07
Posts: 3

Re: Is my bootloder broken?

Thanks MrZack,
At the time I was writing my second post, your post was not submitted yet.
Thank you for clearing out the details.

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2008 PunBB